Cannot click on "Agree" to confirm Terms & Privacy Polices

I have logged in after some time, and system requires me to confirm, but when I click on Agree… nothing happens.

Here is screenshot of the issue: https://screencast.com/t/GkddHIFAUj

Using latest Firefox on OS X… also tried on Chrome.

Hello, I have the exact same problem right now. With firefox on windows 10. Your screenshot shows they made a javascript error. Can’t contact them to fix it. They will eventually fix it I suppose.

Hi Guys,
Sorry for the inconvenience, could you please try again? now should be working properly!
Please let me know if the problem persists! Have a nice day :smiley:

yes, it’s working for me now.

Hi,
I have just tried to log in to my account. When presented with the terms and conditions, I tick the boxes and click accept, whereby I am moved to another Grey screen with a ticked box in it next to “I have read and accept the Terms & Conditions and the Privacy Policy.”. That is all that is shown.
I.e. it does not seem to acknowledge the fact I have accepted anything. I cannot get into my account.

1 Like

I’m having the exact same problem. MacBook Air, Catalina os

Hi! Could you please send me an email to [email protected]?
I will be glad to help you!
But I need more info about your account.
Have a nice day :slight_smile: