Can't Login on iPhone

I have just renewed the certificate for my Prey/Apple account but every time I try to log in on my iPhone I just get some sort of foreign error message???

1 Like

I have the same problem! On my macbook I need to check a box that I’m not a robot (captcha) - this box doesn’t appear on my iphone - instead google opens a website where I can click (check) the box, but nothing else ever happens…

Sometimes I’m able to just go back to login page on iphone where I usually put in my password but then get the massage “wrong captcha”


Hi, I’m very sorry for this inconvenience, could you please try again? If the problem persists, please send me an email to I have already forwarded the problem to our team :slight_smile:
Have a nice day

I deleted the app on my iPhone, reinstalled from the Apple Store, and now it works. Must have been a corrupted update or something.

Hi. I need help logging into my account. Carefully checked my details and tried to login with my normal login credentials but I am getting an ‘invalid login details message’ on my iPhone, mobile browser chrome AND desktop chrome browser. I have changed my password several times and it still wont let me login.
I emailed this to and it was blocked and flagged for spam.

Thanks, Mr B.

I just renewed my certificate for my macbook and trying for my iPhone 13. All good with the mac but I can’t login to my phone account, I just get a spinning circle and “please wait” in front of the Prey logo. It isn’t allowing me to log in to Prey on my phone to complete the installation of the renewed certificate. What can I do?

I couldn’t (and still cann not) login into my ios app, because of wrong password. I can login into my prey user account using the browser and the same password.

After that, I deleted the prey app and re-installed it on my ios device. Now I still can’t login to my account with the app: “The password you entered is incorrect.”
When using the QR-code from my user account from the browser it says:
“Couln’t add your device. Error code 502”
ios 16.3.1
iPhone SE (2nd gen)

1 Like

Here the same problem. I also get the impression that this Preyproject is stalled. No support at all, very old replies on this forum. This product is too buggy for testing.

See my other reported issue as " Installation failures on Iphone13, iOS 16.3.1 of latest Prey version 2.1.16 from App store" Installation failures on Iphone13, iOS 16.3.1 of latest Prey version 2.1.16 from App store

This error code 502 only appears if the device was already registered and/or the maximum amount of devices was reached. Check at under devices. This is one of the buggy parts of the installation process. In the app on the iphone it doesn’t look like the device was successfully registered because it continues with login errors. This probably is related to a double authentication issue which doesn’t seem to work with the app for iphone. Prey does not respond to email sent to support, and here the last respons was in 2019?

We have stopped testing this non-supported app for consideration in our organisation. It appears useless for IPhone with IOS 16.3.1. Not recommended to waste time and money for this product.

After a month not touching the app, I opened the app and voila, I was able to log in to my account with my iphone, and i was able to add my iphone as a device. Whatever caused this error, it’s solved for now! :+1: