Certificate push to iOS 14.2 devices not working

I’ve updated the certificate and done everything listed here:


I select “Allow” in the dialog that says “This website is trying to download a configuration profile. Do you want to allow this?”

But then I get a dialog saying “Profile Downloaded – Review the profile in Settings app if you want to install it”.

And that’s it—nothing happen, and opening the Settings app doesn’t reveal any options.

I’m pretty sure that the Settings app is supposed to automatically open to allow one to confirm the profile, but that’s not happening – see screenshots.

Anyone have any suggestions? Is this a bug or am I doing something wrong?

Thanks in advance!
NO - 2

Hi William!

It seems to me that what you need to do is review the certificate in your iOS device. iOS does not automatically open or install any certificate, so you have to do that manually.

You can do so in the Settings app > General. Once there, scroll down until you find the “Profile” option and tap on it.

Once there, tap on the certificate as per the screenshot below:

And on the next screen tap “Install”.

You should be prompted to enter your iOS passcode and trust the certificate. With that your device should be fully protected and you should be able to execute all actions available from your Panel.

I hope this helped!


Sorry for the delay—this went to my Gmail Spam folder and I just saw it.

Unfortunately, I don’t have a “Profile” setting under “General”. And when I search under “Settings” for “Profile”, I only see the “Health” app. I should have made this clearer—including screen shots.

I am running iOS 14.2.1 — could that explain the problem? If so, I would think a lot of people would be experiencing this…

So appreciate your help!



I found some info on the Apple Developer’s forum, and here’s what I discovered and had to do to make it work:

On iOS/iPadOS 14.2, no “Profiles & Device Management” option is available under “Settings > General” until there is a profile installed. For whatever reason, the Prey certificate is not able to properly trigger the option to install. What I discovered was…

I had to first install the “iOS & iPadOS Beta Software Profile” from Apple here:


Once I’d installed the beta profile and restarted, the “Profiles & Device Management” option became available under “Settings > General” — and when I downloaded the certificate from the preypanel website, it properly triggered the installation.

My guess is that for people with a profile already installed, this isn’t an issue—but for those, like me, who don’t have one and are experiencing difficulties, try the above and let me know! I was incredibly frustrated and couldn’t find anything on the web about it. I did it first on my iPhone and it worked perfectly. Thinking maybe it was a coincidence, I tried on my iPad a few times before installing the Apple profile—but again, it wouldn’t install until after I’d installed the Apple Beta profile, after which it worked perfectly.

Hope this is helpful to someone!


1 Like

Is that true in terms of joining the Apple beta to fix this issue? That’s quite a hassle… is there a fix en route?



1 Like

Hi Rafa,
I am having a similar issue - I receive the push notification on my iPhone 8 but the file is downloaded empty (see screenshot below) and not triggering the installation of the Profile. It’s strange because the same certificate worked well with my MacBook Air. Can you help please? Thanks