Fresh installation on Android not working

Hi all. I have had Prey on several devices over time and it has always worked flawlessly. I recently repaired a broken phone, which had Prey on it before. The device’s software was completely refreshed to create a clean slate. It was also removed from the Prey panel as a device. Now after reinstalling all apps, Prey included, it, Prey, opens to a black screen only. I’ve installed, uninstalled, reinstalled, cleared cache, activated and deactivated device administrator settings. The app shows as installed on my Play store. The phone is a Umi Touch, Android 6. As mentioned, it used to work on the phone before. Any ideas what else could be wrong please? Thanks in advance.

Hi there,

I’m sorry to read that. Could you please:

  1. Go to Android Settings > Security & Location > Device admin apps and disable Prey as one of them.
  2. Go to Android Settings > Apps & notifications > App info > Prey > Storage and clear data.
  3. Go to step #1 and reenable Prey as an admin app.
  4. Open the Prey app again. It’ll ask for your email and password, and that will get the device added to your Prey account once you finish the process.

(Instructions could be a bit different depending on your Android version.)

The problem is caused by Google’s cloud backup, which restored the config file from your old Android device into the new one. These steps will force the new unit to be added.

Please let me know how it goes!

Thank you but as mentioned, I’ve tried it already. When done, I try open the app, but only get a black screen, no log in screen.