I've already installed Prey on my device. Why isn't it showing on my account?

I’ve installed Prey on my android device and It’s not showing on my account.
I have granted all permisions and can access with my account credentials in my device.
But it won’t show in the panel.



1 Like


Occasionally devices can take longer than normal to appear in the Control Panel. Please check again and let us know if the problem continues.


Hi there. Did you migrate your app settings from another device, by any chance?

Hi there, sorry for taking so long to answer.

Is not showing up yet.
I did migrate from another device at first.
But I’ve since unistalled and reinstalled several times.

I see, so that’s the problem then. Could you please check this article? http://help.preyproject.com/article/186-prey-and-time-machine-backups

Hi Fabian,

Thanks for the insight but that article doesn’t help me.
This is an android device we are talking about.

And I have uninstalled and reinstalled Prey many times.

Is there a way to remove config files from Prey app?
That might solve the issue now that I understand how Prey identifies the device.


Oh, I’m terribly sorry! I didn’t notice that it was an Android :frowning:

To fix that, go to:

  1. Android Settings
  2. Apps
  3. Prey
  4. Delete all application data.

That will do the trick :thumbsup:

That fixed it.


1 Like

I’m having this exact issue on a moto g6 Android 8, any idea how to fix it?
I migrated everything from an older phone

Hi @AndyRea,
I’m sorry to read that. Could you please:

  1. Go to Android Settings > Security & Location > Device admin apps and disable Prey as one of them.
  2. Go to Android Settings > Apps & notifications > App info > Prey > Storage and clear data.
  3. Go to step #1 and reenable Prey as an admin app.
  4. Open the Prey app again. It’ll ask for your email and password, and that will get the device added to your Prey account once you finish the process.
    (Instructions could be a bit different depending on your Android version.)

The problem is caused by Google’s cloud backup, which restored the config file from your old Android device into the new one. These steps will force the new unit to be added.

Please let me know how it goes! :slight_smile:

1 Like

Worked like a charm thanks for your time and help

1 Like

Any help for a new MOTO G7? This doesn’t have app info and so I can’t clear Prey’s cache. Help!

Hi @Lindemann, did you tried with this? :slight_smile: