Make it work with Ubuntu 20.04

It won’t install as it depends on python-gtk2 that was removed from the repos.

1 Like

Hi… Download the new version from
And install it using this command:
sudo dpkg --ignore-depends=python,python-gtk2 -i prey_1.9.4_amd64.deb


I’ve installed it, but at the next apt update / upgrade I get:

$ sudo apt upgrade
Lettura elenco dei pacchetti… Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato… Fatto
È utile eseguire “apt --fix-broken install” per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
prey : Dipende: python-gtk2 ma non è installabile
E: Dipendenze non soddisfatte. Provare “apt --fix-broken install” senza pacchetti (o specificare una soluzione).

And I can’t upgrade anything on my system.
You should remove the dependency in the package for 20.04

I had to remove prey.

I checked this and you’re right… I just created another installer that you can download from here:
Then run sudo apt --fix-broken install and uninstall prey completely.
After you download the package install it again with sudo dpkg -i prey_1.9.4_u20_amd64.deb

That should work fine.
Let me know if that works well so I can formalize this solution.

Kind regards,

Same problem, here. Installed the version uploaded to dropbox. Installed with no problems, but on triggering gui config, it crashes.

Hi @lcv,

Could you please tell me how does it crashes? Also paste the terminal output here so I can see the error.


uh, wrong installer. With the dropbox one has worked again.
Thank you.

Dear Staff Member

If this method - the dpkg method - is the one to use, at least on certain popular distributions - then had you better not make that clear somewhere other than in this forum? Compare my unanswered post of two weeks ago, here.

Hi! I also have issues on Ubuntu 20.04… Using the package from Dropbox, installer runs ok with sudo dpkg --ignore-depends=python,python-gtk2 -i prey_1.9.4_u20_amd64.deb, but when I try to connect it, I get an error:

user@workstation:~/Downloads$ sudo /usr/lib/prey/current/bin/prey config panel
Firing up config panel!
A browser tab will now open and direct you to the device link process. If you encounter any issue please visit:

user@workstation:~/Downloads$ sudo /usr/lib/prey/current/bin/prey config gui
EXCEPTION! system is not defined
ReferenceError: system is not defined
    at show_and_exit (/usr/lib/prey/versions/1.9.4/lib/conf/gui/index.js:27:19)
    at /usr/lib/prey/versions/1.9.4/lib/conf/gui/index.js:64:7
    at Object.exports.verify_current (/usr/lib/prey/versions/1.9.4/lib/conf/shared/keys.js:62:12)
    at show (/usr/lib/prey/versions/1.9.4/lib/conf/gui/index.js:51:17)
    at exports.check_and_show (/usr/lib/prey/versions/1.9.4/lib/conf/gui/index.js:69:12)
    at /usr/lib/prey/versions/1.9.4/lib/conf/cli.js:54:7
    at Operetta.parse (/usr/lib/prey/versions/1.9.4/lib/conf/utils/operetta.js:124:7)
    at Operetta.start (/usr/lib/prey/versions/1.9.4/lib/conf/utils/operetta.js:165:14)
    at run (/usr/lib/prey/versions/1.9.4/lib/conf/cli.js:53:11)
    at /usr/lib/prey/versions/1.9.4/lib/conf/cli.js:62:7

No browser tab or GUI opens… Any assistance appreciated, thanks!

I am actually getting the same error as @urko99. Has anyone found a workaround?

1 Like

So this worked for me, starting from a clean environment (no previous good or bad prey dpkg installed package).

I could link it to my account and send alarms+messages from the web app to my computer.
I haven’t tried locking it though. And don’t know if the service will survive a lock-screen or restart.

mkdir -p ~/programs && cd ~/programs
# not this one
# wget
mv 'prey_1.9.4_u20_amd64.deb?dl=1' prey_1.9.4_u20_amd64.deb
sudo dpkg --install ./prey_1.*.deb
cd /usr/lib/prey
# search for `` or similar filenmae
find * -name '*.py'
# manually work this next line, based on the previous output,, andrun with sudo
sudo /usr/lib/prey/versions/1.9.4/lib/conf/gui/linux/
# note: haven't tried with `versions/1.9.4/lib/conf/gui/linux/` though (missing 3 number), but I presume it requires `python-gtk2` and will eventually break in Ubuntu 20.20 (focal)

Hope it helps!

pd: if you need to fully uninstall a bad or old prey installation, this url might be of help:


Worked perfectly also on my machine, thanks!!!

Worked for me as well. Thanks a bunch!

Good information thanks for sharing

broken again with 1.9.6

same issue…is linux still supported?

Thank you info.
Vegus168 เว็บพนันบอล

Ubuntu community about the 20.04 is informative
Quran Recitation with Tajweed

Thanks for sharing this post very information

Big thanks for your great post. We are the provider of isc8888.

See More : ISC888 โปรโมชั่น

ดูหนังใหม่ออนไลน์ HD หนังมาสเตอร์ออนไลน์ฟรี หนัง037 หนังซูมชนโรง ดูหนังออนไลน์ ซับไทย ดูฟรีไม่มีโฆษณาคั่น ดูหนังฟรี ไม่เสียเงิน ได้ที่