"Update button" on a Prey Free account

Hello! Im testing out Prey and I begin with a Prey Free account and installed it on Windows10 and an Android phone (Android 10). When I click the “Update location” button in the admin panel the location does not get refreshed (Nor laptop nor phone). Do you know if this feature should work in the Prey Free version? The weird thing is that the location on the map does update from time to time when I look there (but not after I click the “Update location” button.

Best, J

Let us help you. Please tell us about…

  • Affected device (desktop, laptop, tablet, phone): ???
  • Operating system (Windows, MacOS, Android, iOS, Ubuntu, Fedora): ???
  • Part of Prey not working (Prey account, mobile app, a specific action or module, reports): ???

Could you please describe the problem?

And finally, please attach a screenshot if available (you can drag and drop images)

Hello, just curious if someone might know the answer? kr J

I reported this same problem back in late 2020/early 2021 if I recall correctly. It worked fine with my phones (mine/wifes) but not on any of our laptops (insisted I was still living at my address of 2 yers ago).

The issue was confirmed as a “bug” in the “free” version. I was offered a slightly discounted paid account as a solution.

I have since upgraded to a completely different machine running Windows 11 and upgraded my phone to Android 11/One UI 3.1 and been able to replicate the problem.

I asked the support person if the problem was fixed in the paid version and they couldn’t confirm. I asked why would I pay for a full version if I couldn’t confirm that the problem was solved. They replied they’d never heard of it reported in the paid version so they assumed it was fixed.

I’d be happy to upgrade if they would guarantee it was fixed. I am still waiting for the promised “fix”

Many thanks for the answer - I hope this can be raised to the developers since it seems like it affects many users.