A few issues (Catalina, firewall, wrong device name)

OK, I’ve had some issues, done some troubleshooting, haven’t been able to fix everything. I’ll just list some details and hopefully we can all benefit in some way (even more hopeful that someone has a suggestion):

Got a new laptop, setup the old for my girlfriend, upgraded both to Catalina, made sure to install prey on both machines. I had a previous install, but set my machine up fresh. I actually removed all devices from my account in order to start new. No issues.

Recently, (roughly after I upgraded to 10.15.3), I received an email that my machine was not reporting its status.
I checked and the other laptop is working just fine. Mine shows as offline. Tried uninstalling, re-installing, running cli commands in order to restart the watcher, force connection, etc. Nothing helped.
I run Little Snitch as a firewall, and it is set to allow the node process to access anything it wants. Still not working.
So, I temporarily disabled Little Snitch and then node connects. Great, right? It would be, except it doesn’t make much sense since I was allowing it’s traffic. Also, it not shows as “Susans-iphone-6” for a device name (definitely not correct).
I removed all the files, again, and reinstalled, again; same thing happened. Susan’s iPhone showed up again. I double-checked the /etc/prey/prey.conf file and the device key is different from before. So why would it show up as the same (and still incorrect) name? The api key remained the same, and matches my account, for what that’s worth.
The details of the device match my machine, which makes sense since it’s pulling the data from where it is running. What I don’t understand is why it previously worked, with the firewall running, but now it does not.

Also, all security/privacy options, where prey or node are listed, are enabled (such as screen recoding, full disk access, etc).

Any help/ideas would be greatly appreciated.


I’ll check with the firewall company to see whether something is odd there as well, because I’ve noticed that there are two monitored entries for node, one with a rule (allowing traffic), and one which seems to be getting blocked (possibly) but has no rule (and no option to add one).

But the thing that really gets me is why the device (when no firewall exists) is showing up as susans-iphone-6, regardless of the device key in prey.conf. That seems really odd to me.

Found this thread:

it mentions running the firewall’s config as the prey user:
#p30908 (by fastasleep)
sudo -u prey /Applications/Little\ Snitch\ Configuration.app/Contents/MacOS/Little\ Snitch\ Configuration

I ran that, approved the proper rules, and now things properly connect. So that’s cool. The firewall part is resolved.

But, why the hell does my machine show up as a different name? I double-checked my machine sharing settings, network name, etc, and it all says “jorsh-mbp”, as expected. NOT susans-iphone-6.

Any help with that one would be appreciated, still.