Cannot Add New Device

Let us help you. Please tell us about…

  • Affected device (desktop, laptop, tablet, phone): LAPTOP
  • Windows Version WINDOWS 11
  • Part of Prey not working (Prey account, mobile app, a specific action or module, reports): CANNOT ADD DEVICE TO ACCOUNT

Could you please describe the problem?

After successful install of current version of Prey for Windows (x64), a new Chrome tab opens to “CONNECTING TO PREY SERVER” and that’s where it stops. I’ve uninstalled, reinstalled, and even forced the Prey config via Power Shell command and the same result. One other issue similar to this has been reported with no public reply aside from other users saying they’re having the same problem.

And finally, please attach a screenshot if available (you can drag and drop images)

1 Like

I have the same problem with a brand new Dell Inspiron 16 running Windows 11. Stuck at the same Connecting with Prey Servers screen.

Hey J_S!

Are you still having issues?

Hey gotravelant!

Yesterday we were having some issues on our end, but right now it seems everything is working fine. Can you please try again?


Nope, still doesn’t work.

That’s a shame. Are you perhaps using a VPN or something similar on your device? Or perhaps connecting to a wifi network inside a VPN?

No VPN here. Other 2 laptops in the network are fine, just not this new one.

Sorry for getting to you so late!

Are you able to upload your prey.log so we can help you?
(Edit: I’m sorry, but I didn’t tell you where is this “prey.log” file haha. It’s located in C:\Windows\Prey)