Not able to install on Catalina, write permissions needed

After upgrade to Catalina, my MBP (2017) was not visible anymore in the prey panel. Received a notification on this issue via email. Removed te device and tried to perform a fresh install. Followed the instructions to install an app not from app store. After installation and selecting my account from web browser, received a message that device could not be connected to Prey.
Then opened the PreyConfig app from search menu. When loggin in with existing account, receive the following message: “Error! Oops. Seems you don’t have write permissions. Try running with sudo.”
Unfortunately cannot find a solution on this forum. Anyone who can help me? Would be highly appreciated. Kind regards, Bart


Hi Bart,

From the terminal you can try with the command:
sudo /usr/local/lib/prey/current/bin/prey config gui

Let me know if that works for you


Thank you! I’m having the same issue as OP, also on a 2017 MacBook Pro running Catalina. I tried your suggestion and wanted to update you that it worked perfectly.

I ran that command and a new Prey Configurator window popped up on top of the old one. I logged into this new one and it connected to my account.