Please add Pop_OS! 20.04.0 64 bit LTS

I am having problems adding my late 2019 Computer Upgrade King Hewlett Packard Omen 15t gaming notebook PC running Pop_OS! 20.04.0 64 bit LTS GNU/Linux to my Prey Project account. When I try the GUI, it never adds my PC to my account and I have to exit. When I try the command line and I enter my unique API key, it says that my OS is invalid. Please fix this so I can add my PC to my Prey Project account and let me know. Thanks.

I have read some of the threads here related to Ubuntu 20.04.0 64 bit LTS GNU/Linux and I followed some of the troubleshooting steps and Prey will not add my PC to my account. I am at a loss as to how to get my PC added to my account. For now, I uninstalled Prey Project as cleanly and safely as possible. What steps and information do you need from me so I can add my PC?

Same Problem here, read all Information, but nothing really worked. Went several time through the authorisation process.
I clearly understand your policy to Limit Support to Ubuntu, but it worked before on other distribution based on other Releases of Ubuntu (for example elementary OS). On the New notebook I had to go to an other distribution, because of the missing AMD Support of the older Kernels.

I am trying to install Prey on Pop! OS version: Linux ryloth 5.4.0-7634-generic #38~1591219791~20.04~6b1c5de-Ubuntu SMP Thu Jun 4 02:56:10 UTC 2 x86_64 x86_64 x86_64 GNU/Linux, which is actually Pop! OS:

Distributor ID:	Pop
Description:	Pop!_OS 20.04 LTS
Release:	20.04
Codename:	focal

I’m wondering if anyone has gotten this to work, given that it’s basically an Ubuntu distribution?

Seems like a common problem to all distros who are not a pure Ubuntu System.

Mine is a Arch, package obtained by AUR.

This is the output from terminal:

sudo prey_project config account setup -f

Do you already have a Prey account? 
 - yes/no: [yes] yes
Well hello old friend!
Please type your account's email address. 
 - email: (redacted)
Well played. Now enter your password. 
 - pass: **************
Credentials verified.
Linking device...
Error! 
Os:  does not exist.

At least no solution or interest into this toppic, as we are Not paying Customers. A little bit disappointing ad the solution would be to add a string for the OS on the Server, nothing more we wish.

Hi, guys,

I’m sorry to be the bearer of bad news, but we no longer support non-Ubuntu Linux distributions. We just took that decision and have no current plans to reverse it.

This is not because we’re evil, lazy, or whatever. The truth is that we’re a very small team, currently supporting five different Prey clients, and don’t have the resources to support everything as well as we’d like to. We tried for years, and now we know we can’t provide a good experience for all distros out there. That’s why we decided to focus on Ubuntu.

I hope you understand.

So why are some Ubuntu based OS supported (Mate for example) and others Not?

They are not supported. Some distributions can still be added because of legacy code, but that doesn’t mean that Prey will work on them.