Shield off-button not working correctly?

Hello fellows,
I’m seeing something that would be great if it worked like I expected it to but seems to be not the case. I’m using a Motorola Moto G4 Plus and on the Prey settings screen there’s an option that says “Shield OFF button when Prey-locked”. “GREAT” I think. “If I ever have to activate Prey on my device, they won’t be able to power off the phone”. However, what really happens if I activate this option is that the off button is permanently blocked, asking for a PIN every single time, be Prey activated or not.

Is this normal?

Thanks a lot!

Hi Andres,
Yes, the idea is to prevent your phone from being turned off, even before you notice it is lost. That is the reason why it works constantly. If you don’t want this function, you can disable it in the settings of your Prey panel.
Please let me know if I can help you with anything else!
Have a nice day :slight_smile:

Doesn’t appear to work for Samsung devices as they can still be turned off without the PIN lock.

Hi @nevezen, please check your DM :slight_smile:

It is not working either in my Honor 9 Lite!

It is not working either in my Honor 9 Lite! Can you help me? Thanks in advance.

I’m a new user. Its not working on oreo 8.1.0, I have no persistant notification either.

We’ll be releasing a new version of Prey later today that fixes the problem. Thanks everyone for your patience.

Sorry for late reply but 6 months later, problem still persists. I am using a Samsung Galaxy Note 5 with Android Nougat. Here’s a (recent) screenshot of it in action. Note how the Prey PIN unlock is in the background of the power menu foreground…


My phone powers off without even showing anything from the prey app.

I double checked the settings and everything is correct.

My phone is HUAWEI Mate SE with Android 8

I have the same problem. It doesn’t work on my device either. It’s a HUAWEI Mate 10 Pro.

Hi guys, could you please check if the option “run in background”? you have to go to the App settings on the device :slight_smile:

Yes, “Run in Background” is enabled :slight_smile:

Yes with me also. Run in background enabled. About a week ago, I misplaced my phone. Prey could not make contact with my phone.

This happened once before.

Pray isn’t much good if it can’t find your phone.

I uninstalled it and am using Google’s Find My Device.

It doesn’t have the features Pray does, but at least it can find my phone.

Hi, I’m very sorry to read that :frowning: please, if you want to solve this inconvenience I will be very glad to help you, you can also send me an email to if you have any question. Have a nice day :sunny: