Troubleshooting Prey after macOS High Sierra update

UPDATE 11/02
As of today, Prey’s latest version includes an automatic fix that detects if the High Sierra/Sierra update compromised the Prey installation and solves it.

However, since Prey requires administrator permissions on installation to execute this fix, users that already have Prey installed on their Mac computers, have to execute the following command on their computer’s terminal:

sudo /usr/local/lib/prey/current/bin/prey config hooks set_watcher

This will ensure Prey is given the proper permissions to execute the fix on your system and avoid any kind of issues when facing a Sierra/High Sierra OS update.

Hi everyone! We have recently received several red flags from users that had updated to macOS High Sierra, notifying that Prey stopped working after the new OS was installed.

This is caused by the following:


  • When Prey’s installed in Mac, it creates a secret user it utilizes to operate without needing root.

  • After a Mac is updated to High Sierra, this user is eliminated, and thus, Prey stops working.

We’re aware of it and we are working on a release that’ll automatically detect and fix the error. However, it is possible to fix your macOS High Sierra Prey installation now, following one of the following methods.

Two quick fix options you can implement now:

  1. Download and execute this patch to automatically solve without reinstalling.

  2. Or Download and reinstall Prey to also fix the issue.

1 Like

Hi, I recently updated to High Sierra, Prey couldn’t find my laptop, then ran the Patch from 1) above. The Patch completed without errors according to its text output. However, despite restarting laptop it is still not found.

What’s the next step that you suggest to further troubleshoot this?

Thank You!


Hi @bsmarine,

If you have installed 1.7.2 or above you just have to run the command: sudo /usr/local/lib/prey/current/bin/prey config hooks set_watcher in the terminal, that should fix the problem right away and never have to worry about it again.
If that doesn’t work just reinstall prey.



  1. from above worked even though 1) did not.

Out of curiosity, how does one remove Prey from a system if conflicts with new unrelated software arise?


I still have the issue. I am running High Sierra 10.13.3 on a 2014 Mac air. I have Prey 1.7.3 installed on the mac and have just re-installed it due to the location not being able to be found. I have also inputted the command line in terminal to which the response was that it was already running.

Can you please update on what the issue is and how I can resolve.


1 Like

Could you attach you /etc/prey/prey.log file here? Also run this command id-g prey and paste the answer here.

1 Like


Upon pasting id-g prey, in terminal, the response was ‘command not found’

upon searching the extensions folder, there was nothing under prey…

Upgraded from Sierra to Mojave (on 10.14.15), and ran into problem with Prey not recognising MacBookPro location.
Ran the sudo command in Terminal, with no effect. Subsequently ran the patch as per 1. above. Did the trick, all sorted.
Many Thanks,