Upgraded but still loading old version on two Windows computers

Let us help you. Please tell us about…

  • Affected device (desktop, laptop, tablet, phone): Desktop
  • Operating system (Windows, MacOS, Android, iOS, Ubuntu, Fedora): Windows 10 Pro 1803
  • Part of Prey not working (Prey account, mobile app, a specific action or module, reports): Upgrade

Could you please describe the problem?

Received an email that Prey auto-update failed. Manually upgraded from 1.8.1 to 1.8.2. During the upgrade, it said it was completely uninstalling the old version. After the upgrade (and a reboot, although not requested), the dashboard reports that the the machine is still running 1.8.1. The installation folder contains both the old and new versions. Tried another machine, with the same results.

A third machine must have auto-upgraded successfully because it shows 1.8.2.

And finally, please attach a screenshot if available (you can drag and drop images)

Hi @mcbsys,

It’s expected that the device preserve the last prey version in case an error occurs.
About the client version could you run this C:\Windows\Prey\current\bin\prey --version on your command prompt? That should tell you the running prey version on your device, let me know the answer of that and if you still see 1.8.1 on your dashboard.


@javo, the command line shows 1.8.2. Dashboard still shows 1.8.1, although it says it last heard from the device 7 days ago. This device is always on, always logged in, and always connected to the Internet.

Tried the old trick of killing node.exe, which immediately restarts, but the device still does not update in the dashboard.

Also tried killing wpxsvc.exe (CronService), which also restarted, but no change.

In prey.conf, api_key and deivce_key are empty. Is that normal?

# Host to connect to.
host = solid.preyproject.com

# Protocol to use. Either http or https.
protocol = https

# Your account's API key.
api_key = 

# Your device's unique key.
device_key =

Probably when the client was uninstalled the credentials were deleted.
Run this command C:\Windows\Prey\current\bin\prey config panel, that’s gonna open a new tab in your browser so you can re-configure your device and then redirects to the control panel.

Why would it de-register the device during an upgrade?

I restored prey.conf from the day before the upgrade. The device was immediately “back in sight” and the dashboard now shows 1.8.2.