Win10 Laptop can't connect with Prey Servers

Affected Device and OS:
Laptop: ASUS X556UA) with Windows 10 (64 bit)

I can’t add my laptop to my prey account. I downloaded the installation package on the laptop.
After a succesfull installation, a firefox internet browser opened with the standard
installation question if I already have an account to sing in with, or if i want to create a new account.

After entering my account credentials and succesfully loggin in, the webpage appeared
‘Connecting with prey servers’ prey servers screenshot|690x369

However, no new pages were loaded afterwards. As if the connection process got stuck.
When I pressed F5 to refresh the connecting page, my Prey account showed up, but the laptop
was not connected.

I tried unistalling and reinstalling prey on the laptop serveral times. And ended up with
reproduction of the issue: a succesfull installation, but no possibity to connect to the Prey Servers.

Does anyone know what the issue is and how to fix this?!


@mbrussaard did you ever find a fix?

I’m getting same issue. Anyone have a fix for this?

1 Like

I am facing the same issue with Win machine registration with prey 1.9.5 version. One of my existing windows laptop whoch was earlier running fine on prey 1.9.4 is no longer showing reports in version prey 1.9.5. Did the new server version 1.9.5 break the application? Is there a way to stick to prey version 1.9.4?

1 Like

Hello, getting the same problem here. I have Win10 laptop, i registered as a new user through the website, then downloaded the installer, a new tab opened and all it says is “Connecting with PREY servers”. It has been like this for hours, I really need to add my device today. Anyone know what to do or how to fix this issue?

1 Like

I have tried both 1.9.4 and 1.9.5 and its still the same.

So Prey is now unusable till they fix the issue

1 Like

Can we actually forward this thread to the technical support or someone more competent?


need to find a way to highlight this bug to prey guys. This is a disruption

1 Like

Hi There,
Sorry about this! We had some troubles with our service, but we have already made a fix for this bug.
Could you please try again? Let me know if the problem persists.
Have a nice day,


I want to enable and disable the Webcam photos from laptop. Is there any utility from where I can do that for the prey monitored laptop running on Windows 10. Prey client is 1.9.5.

yes the problem still exists , I have made a separate thread for my problem with screenshots and received no responses , then found this thread that talks about the same issue , and did as you advised and attempted again but still the same problem

After giving up on getting this to work on Windows 10 (using Surface Pro) a long time ago, I tried a few things today and finally seemed to work.

Try the following:

  1. Uninstall Prey on Win10. You do this by going to C:\Windows\Prey and clicking the “uninstall” app (I ran as an administrator just in case). Afterward, you may also want to delete the C:\Windows\Prey folder.
  2. Remove the Win10 device from your Prey Account (if it is still listed)
  3. Download & reinstall latest version of Prey for Win10. I used the 64 bit version.
  4. At this point - you’ll go through the process of connecting to the Prey servers via the browser (as above screenshots). This probably won’t work.
  5. Close the browser. Open the cmd prompt in Windows (be sure to right click on the cmd app and select ‘run as administrator’)
  6. Type the below:
    C:\Windows\Prey\current\bin\prey config gui -f
    Hit enter
  7. Follow on screen dialogues
  8. Log into your online account and see if Win10 device has connected

At step 7 - rather than use the browser to connect to prey servers, it has some local method of connecting which seemed to work for me. My online Prey account is now showing my laptop and even has the live location again. Fingers crossed the connection keeps going!


I tried your steps and have partial success.
Prey Configurator shows me congrat message, but web panel is still empty (“No devices tracked”).


1 Like

Hi. Having same issue with Prey 1.11.0 at Ubuntu 22.04. “Connnecting with Prey Servers”:

Thank you very much! finally worked.

I’ve tried on both Android and Windows 11. Neither works.

I can log into my prey (web) account without incident but it shows no devices.
I tried the “C:\Windows\Prey\current\bin\prey config gui” (Windows) and while it said it was successful, no device shows up in my account.

I’ve tried 2 different Android machines with identical results.
Something is messed up. My account is listed under

On a related note: one of the reasons I started this effort was that Prey insisted on situating my laptop at a location where I haven’t lived for almost 4 years. I followed all of the troubleshooting tips from your website but no change.

Google maps pinpoints my location within a few yards. No other application seems to have any issue using location services to pinpoint where my laptop is. This has been an ongoing issue for a few years (I’ve reported it multiple times but had no solution provided).