Prey 1.9.4 installation failure on Mint 19.3

I downloaded the .deb and tried - and failed - to install it, using the graphical installer (that is called Gdebi). The log (which your site will not allow me to upload) is, temporarily, here. Please advise.

My system

OS: Linux Mint 19.3 Tricia x86_64
Host: 20KHCTO1WW ThinkPad X1 Carbon 6th
Kernel: 5.6.7-050607-generic
Shell: bash 4.4.20
Resolution: 2560x1440 @ 60.01Hz
DE: Cinnamon
WM: Mutter (Muffin)
CPU: Intel i7-8550U (8) @ 4.000GHz
GPU: Intel UHD Graphics 620
Memory: 3950MiB / 15907MiB
Disk (/dev/nvme0n1p4): 20G / 40G (52%)
Disk (/dev/nvme0n1p2): 161G / 405G (42%)
Disk (udev): 0 / 7.8G (0%)

Actually, it seems that perhaps the installation has succeeded, and only a post-installation script failed. But (1) should I worry? (2) why did it fail / should that be fixed? Also (3) so far as I can tell, neither the announcements nor the news fora - both of which seem rather empty - contain anything on Prey 1.9.4, even though that release is cross-platform and even though the Windows version is on MajorGeeks.com.

EDIT: the post-installation script is now throwing an error when I install other software. This is far from the first problem I have had with Prey. I do tire of these problems. Still, I am on Mint and I discover - belatedly - that Prey supports only ‘Ubuntu systems’. Does Mint count?

Installing the package, from the terminal, and from a second time, seemed to fix the installation problem - though (see my post immediately above) I have not yet tried to install any other software. The second installation of Prey 1.9.4 even opened my browser, as it intends to. Yet, it was the wrong browser - i.e. not my default browser. Also: doing the upgrade in a terminal blocks package managers until the (wrong) browser window is closed. This mess gets worse and worse.

EDITED.